Boost logo

Boost :

Subject: Re: [boost] Survey: What should an immutable byte sequence data structure be named?
From: Daniel Trebbien (dtrebbien_at_[hidden])
Date: 2011-01-29 10:45:33

On Fri, Jan 28, 2011 at 12:50 PM, Gregory Crosswhite
<gcross_at_[hidden]> wrote:
> Hey everyone,
> To gather more data about what the community thinks an immutable byte
> sequence data structure should be called (given that "string" has already
> been taken), I have created the following poll:
> If you have an opinion on the matter, please consider visiting the above
> link and submitting your favorite name.
> Some names that have been tossed around are istring, immutable_string,
> chain, rope, yarn, twine, cord, but don't feel limited to these choices.
> Cheers,
> Gregory Crosswhite

I suggested `bytes`. I think that this plays well with the STL style
of keeping names short and succinct, and it also makes sense when
considering that the compile-time constant ratio template is named

To me, `chain`, `rope`, `yarn`, `twine`, and `cord` have special
meanings or indicate something special about the implementation,
especially `rope` and `cord` which make me think of the cord type that
is provided with the Boehm garbage collector

Boost list run by bdawes at, gregod at, cpdaniel at, john at