Subject: Re: [boost] [Memory Managed Pointer] Review Request
From: Jeremy Maitin-Shepard (jeremy_at_[hidden])
Date: 2011-04-25 16:51:04
On 04/25/2011 12:41 PM, Joel Young wrote:
> Phil Bouchard<philippe<at> fornux.com> writes:
>> I apologize for all the confusion but I renamed once more the memory
>> manager to mm_ptr. Its documentation is accessible at:
> Memory Managed Pointer and mm_ptr for short are much better names.
Arguably mm_ptr is a bit too generic: managed is a rather general term
that would seem to encompass a wide range of potential strategies, of
which your library implements just one. I'm not sure what the best term
might be, but the "union" behavior does seem to be a key characteristic.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk