Subject: Re: [boost] [Review] Type Traits Extension by Frederic Bron - Review summary and decision
From: Christian Holmquist (c.holmquist_at_[hidden])
Date: 2011-04-28 11:22:36
On 28 April 2011 07:14, Max Sobolev <macsmr_at_[hidden]> wrote:
> On 28.04.2011 15:57, Joachim Faulhaber wrote:
>> Here is my proposal for the operator trait names.
>> Consistent with my preference on cross library and c++ standard naming
>> consistency these are the collections of names that are (measurably)
>> most consistent with the names used for operators in the standard
>> (header<functional>), Boost.Proto and other Boost libraries. [...]
> To save you some time, I have inserted my proposal as *column D* into the
>> Wiki at
> nearly optimal for me
+0.5. As a frequent user of Boost.TypeTraits, the names suggested by Joachim
Faulhaber would be the ones I would look for.
* I would prefer to see the word 'bitwise' instead of 'bit' however.
* To be consistent with at least proto, has_left_shift should be
has_shift_left (in all permutations of left/right + assign)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk