Boost logo

Boost :

Subject: Re: [boost] [gui] Help with a little experiment.
From: Joel falcou (joel.falcou_at_[hidden])
Date: 2011-06-18 11:24:02


On 18/06/11 09:55, Artyom Beilis wrote:
> Please tell me how is this better, more readable, maintainable then
> this code:

No specific GUI API calls.

> 1. Where button is created and who owns it?

It is a lazy function buildign up the AST of describing the window
dialog. There is nothign to own there. The window::operator= take care
of the marshalling of data inside this.

> 2. How do I connect signals afterward?

I can't see why we cant have an iterator coming from window over its
widget and said internal widget to have a way to do so.

> 3. How would an average programmer would understand a error
> codes you would see?

By writing this right so error at caugth at proper level. That's a long
time we have tool for that (first being proto grammar validation). See
Eric post on the subject on cppnext.com

> Making a GUI library is not about providing
> nice syntactic sugar for building layout.

It is. There is aplenty core GUI stuff around. If anything, if Boost
should have a GUI library it should be just this: thin, synatxically
nice layer on top of a generic view of existing core GUI stuff.

> This ^^^ would only the library less useful for average
> programmer who actually needs to write a real code
> for real application... Not in a fancy world of Proto...

Proto world is not fancy, it is rather real.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk