Boost logo

Boost :

Subject: Re: [boost] [TTI] Review
From: Vicente Botet (vicente.botet_at_[hidden])
Date: 2011-07-12 00:16:33

Stewart, Robert wrote:
> Edward Diener wrote:
>> On 7/10/2011 7:59 PM, Lorenzo Caminiti wrote:
>> > Review of Boost.TTI 2011-07-10 (Lorenzo Caminiti)
>> > 10. [NOTE] I think "member variable" is a more accepted name
>> > that "member data"-- isn't it? If so, I'd rename MEMBER_DATA
>> I can understand your preference. I will consider it.
> They are called data members, not member variables, in C++. Names like
> "member variable" come from other languages.
> I don't use "member data" generally, but to me it describes data members
> collectively, not singularly.
> I recognize the desire to keep the prefixes alike, but I'd rather see
> "HAS_DATA_MEMBER" to be consistent with Standard terminology.

+1. Following the standard terminology will avoid confusion.


View this message in context:
Sent from the Boost - Dev mailing list archive at

Boost list run by bdawes at, gregod at, cpdaniel at, john at