Subject: Re: [boost] [TTI] Review
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2011-07-11 10:56:00
Edward Diener wrote:
> On 7/10/2011 7:59 PM, Lorenzo Caminiti wrote:
> > Review of Boost.TTI 2011-07-10 (Lorenzo Caminiti)
> > 10. [NOTE] I think "member variable" is a more accepted name
> > that "member data"-- isn't it? If so, I'd rename MEMBER_DATA
> > to MEMBER_VARIABLE.
> I can understand your preference. I will consider it.
They are called data members, not member variables, in C++. Names like "member variable" come from other languages.
I don't use "member data" generally, but to me it describes data members collectively, not singularly.
I recognize the desire to keep the prefixes alike, but I'd rather see "HAS_DATA_MEMBER" to be consistent with Standard terminology.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer using std::disclaimer;
Dev Tools & Components
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.