Boost logo

Boost :

Subject: Re: [boost] [lockfree review] rfc: naming and interface
From: Dave Abrahams (dave_at_[hidden])
Date: 2011-07-23 11:03:58

on Thu Jul 21 2011, Joshua Juran <> wrote:

> I generally prefer plain English over acronyms -- especially since
> stack and queue are terms and concepts well-understood by computer
> scientists, but LIFO and FIFO may require mentally deducing which one
> is which. So my vote is on "stack" and "queue".
> As for "ringbuffer", I would consider shortening it to just "ring".

Not bad. Alternatively, consistency with the C++ standard would argue
for something like wait_free_queue.


Dave Abrahams
BoostPro Computing

Boost list run by bdawes at, gregod at, cpdaniel at, john at