Boost logo

Boost :

Subject: Re: [boost] [lockfree review] rfc: naming and interface
From: Joshua Juran (jjuran_at_[hidden])
Date: 2011-07-21 05:58:34

On Jul 21, 2011, at 2:46 AM, Tim Blechmann wrote:

> i am starting a new thread, because i want to start a new
> discussion on one
> aspect of boost.lockfree: the naming of the data structure and the
> interface
> naming:
> the current names of the data structures are fifo, stack and
> ringbuffer. during
> the pre-review some people suggested to use different names, lifo
> instead of
> stack or queue instead of fifo.
> in general i think it is a good idea to use a consistent naming
> (probably fifo
> should be renamed to queue), but how does the ringbuffer come in?
> it is a queue
> as well, but with different characteristics (spsc and wait-free).

I generally prefer plain English over acronyms -- especially since
stack and queue are terms and concepts well-understood by computer
scientists, but LIFO and FIFO may require mentally deducing which one
is which. So my vote is on "stack" and "queue".

As for "ringbuffer", I would consider shortening it to just "ring".


Boost list run by bdawes at, gregod at, cpdaniel at, john at