|
Boost : |
Subject: [boost] Name and Namespace for Potential Boost Extended Floating-Point
From: Christopher Kormanyos (e_float_at_[hidden])
Date: 2011-08-30 15:08:46
Hello,
We are seeking a good name for a potential boost extended precision floating-point library.
This is a multiple precision floating-point type which *behaves* well in C++.
The original thread announcing this potential library is here:
http://lists.boost.org/Archives/boost/2011/06/182334.php
Some very helpful boosters are assisting me with the preparation of this potential library.
We've still got a lot to do, but are making good progress.
In order to continue, we need a good name for a potential boost multiple-precision floating-point type.
For the multiple-precision real type we have names like:
* multiprecision_real
* mp_real
* extended_float_tOur current favorite is the second:mp_real.
For namespaces, we have:
1. boost::mp::mp_real
2. boost::multiprecision::mp_real
3. boost::multiple_precision::mp_realOur current favorite namespace is number 2: boost::multiprecision.
This new data type behaves like a drop-in replacement for a POD.
It also has a collection of transcendental functions and a complex data type.
So we are proposing:
namespace boost
{
namespace multiprecision
{
class mp_real { ... }; // The real data type.
class mp_complex { ... }; // The complex data type.
mp_real sin(const mp_real&); // The sin function for the real data type.
class mp_uint { }; // A potential future multiple-precision unsigned integer type.
class mp_int { }; // A potential future multiple-precision signed integer type.
}
}
We would appreciate comments (negative or positive) and/or alternative suggestions for names.
Thank you. Sincerely, Chris.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk