Boost logo

Boost :

Subject: Re: [boost] Name and Namespace for Potential Boost ExtendedFloating-Point
From: Sylvester-Bradley, Gareth (Gareth.Sylvester-Bradley_at_[hidden])
Date: 2011-09-01 16:31:14

> So this is the last call for anyone who can't live with it.

Since you're still asking... :-)

> * I believe we received more positive feedback for "a variation of float...", neither real nor decimal.
> * The consensus seems to be that the namespace mp is terse and confusing.
> * Some like the trailing underscore. Most, however, do not favor it.

+1 all from me.

> namespace boost
> {
>  namespace multiprecision
>  {

OK, so far...

>    class floating { };
>  }
> }

Please no! I'd expect a class name like this to be a noun (possibly preceded by adjectives). Am I alone?

My vote goes to the following, already mentioned earlier:

namespace boost
  namespace multiprecision
    class mp_float;


The information contained in this message or any of its attachments may be confidential and is intended for the exclusive use of the addressee(s). Any disclosure, reproduction, distribution or other dissemination or use of this communication is strictly prohibited without the express permission of the sender. The views expressed in this email are those of the individual and not necessarily those of Sony or Sony affiliated companies. Sony email is for business use only.

This email and any response may be monitored by Sony to be in compliance with Sony's global policies and standards

Boost list run by bdawes at, gregod at, cpdaniel at, john at