Boost logo

Boost :

Subject: Re: [boost] [Review:Algorithms] is_ordered name
From: Marshall Clow (mclow.lists_at_[hidden])
Date: 2011-09-24 12:06:00

On Sep 24, 2011, at 5:33 AM, Brent Spillner wrote:

> On Sat, 24 Sep 2011 09:34:59 joaquin wrote:
>>> Isn't this the same as the C++11 is_sorted_until?
>> Yes! C+11 had is_sorted_until and is_sorted (equivalent to is_sorted_until(first,last)==last). I think the names here should be the same for >consistency reasons, and probably the functions should be just aliases to the c++11 ones where applicable.
> With the RV convention change that I proposed on github (always point
> before the first element that is out-of-order with respect to its
> predecessor, rather than the first that is out-of-order with respect
> to its successor), it would be exactly the same, so I think we may be
> stuck with this name, even though I agree that it sounds like it
> should return a bool.

That may be the best solution, but dang, I think that's an awful name.

-- Marshall

Marshall Clow Idio Software <mailto:mclow.lists_at_[hidden]>

A.D. 1517: Martin Luther nails his 95 Theses to the church door and is promptly moderated down to (-1, Flamebait).
        -- Yu Suzuki

Boost list run by bdawes at, gregod at, cpdaniel at, john at