Subject: Re: [boost] [Review:Algorithms] is_ordered name
From: Brent Spillner (spillner_at_[hidden])
Date: 2011-09-24 08:33:00
On Sat, 24 Sep 2011 09:34:59 joaquin wrote:
>>Isn't this the same as the C++11 is_sorted_until?
>Yes! C+11 had is_sorted_until and is_sorted (equivalent to is_sorted_until(first,last)==last). I think the names here should be the same for >consistency reasons, and probably the functions should be just aliases to the c++11 ones where applicable.
With the RV convention change that I proposed on github (always point
before the first element that is out-of-order with respect to its
predecessor, rather than the first that is out-of-order with respect
to its successor), it would be exactly the same, so I think we may be
stuck with this name, even though I agree that it sounds like it
should return a bool.
If we were starting from scratch my first impulse would be
end_of_ordered_prefix(), but that too seems wordier than the ideal.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk