Subject: Re: [boost] BOOST_FORCE_INLINE
From: Niels Dekker - address until 2014 (niels_dekker_address_until_2014_at_[hidden])
Date: 2011-10-09 13:32:03
Beman Dawes wrote:
> On Sun, Oct 9, 2011 at 12:34 PM, Mathias Gaunard
> <mathias.gaunard_at_[hidden]> wrote:
>> On 10/09/2011 04:57 PM, Vicente J. Botet Escriba wrote:
>>> Le 09/10/11 15:30, Mathias Gaunard a écrit :
>>>> I would like a BOOST_FORCE_INLINE macro to be added to
>>> What do you want BOOST_FORCE_INLINE to be replaced for?
>> As the name suggests, __forceinline or __attribute__((always_inline))
> What compilers provide support? Do they spell it the same way?
If one compiler spells it as '__forceinline', while another calls it
'always_inline', I'd suggest naming the macro 'BOOST_FORCE_ALWAYS_INLINE'.
My 2 cents, Niels
-- Niels Dekker http://www.xs4all.nl/~nd/dekkerware Scientific programmer at LKEB, Leiden University Medical Center
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk