Boost logo

Boost :

Subject: Re: [boost] BOOST_FORCE_INLINE
From: Mathias Gaunard (mathias.gaunard_at_[hidden])
Date: 2011-10-09 15:52:02

On 10/09/2011 06:56 PM, Beman Dawes wrote:
> On Sun, Oct 9, 2011 at 12:34 PM, Mathias Gaunard
> <mathias.gaunard_at_[hidden]> wrote:
>> On 10/09/2011 04:57 PM, Vicente J. Botet Escriba wrote:
>>> Le 09/10/11 15:30, Mathias Gaunard a écrit :
>>>> I would like a BOOST_FORCE_INLINE macro to be added to
>>>> boost/config/suffix.hpp
>>> What do you want BOOST_FORCE_INLINE to be replaced for?
>> As the name suggests, __forceinline or __attribute__((always_inline))
> What compilers provide support? Do they spell it the same way?

MSVC has __forceinline, GCC has __attribute((always_inline)), which
other compilers probably have as well (at least XL C/C++ seems to
support the same syntax as GCC).

Boost list run by bdawes at, gregod at, cpdaniel at, john at