Subject: Re: [boost] Boost.Algorithms request
From: Marshall Clow (mclow.lists_at_[hidden])
Date: 2011-10-09 18:45:14
On Oct 9, 2011, at 3:11 PM, Joshua Juran wrote:
> On Oct 9, 2011, at 5:28 AM, Zoltán Tóth wrote:
>> I ask to change the name of function is_ordered(). The "is_" prefix
>> suggests that it is a boolean function which it is not. Also, there
>> are other functions there with prefix "is_" and which are boolean
>> functions, and this non-uniformity hurts the eye. I suggest the name
> Another possible name is "first_out_of_order". I'm not sure I like it better, but maybe someone else does.
I think the consensus is that if we change the name, it should be changed to "is_sorted_until", which is what the C++11 standard uses.
Marshall Clow Idio Software <mailto:mclow.lists_at_[hidden]>
A.D. 1517: Martin Luther nails his 95 Theses to the church door and is promptly moderated down to (-1, Flamebait).
-- Yu Suzuki
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk