Boost logo

Boost :

Subject: Re: [boost] Boost.Algorithms request
From: Joshua Juran (jjuran_at_[hidden])
Date: 2011-10-09 18:11:33

On Oct 9, 2011, at 5:28 AM, Zoltán Tóth wrote:

> I ask to change the name of function is_ordered(). The "is_" prefix
> suggests that it is a boolean function which it is not. Also, there
> are other functions there with prefix "is_" and which are boolean
> functions, and this non-uniformity hurts the eye. I suggest the name
> "first_misordered".

Another possible name is "first_out_of_order". I'm not sure I like
it better, but maybe someone else does.


Boost list run by bdawes at, gregod at, cpdaniel at, john at