Boost logo

Boost :

Subject: Re: [boost] [stratified] library for micro-/userland-threads
From: Lars Viklund (zao_at_[hidden])
Date: 2012-07-03 03:24:40

On Tue, Jul 03, 2012 at 08:16:53AM +0200, Oliver Kowalke wrote:
> > Perhaps it's too late to suggest this, but could the library be given a
> > more meaningful name than "stratified"? Perhaps "fiber" as that's what's
> > being implemented?
> fiber (Windows specific) - was one of its previous names like:
> fiber, strand, stratified, tasklet, ...
> I'm not sure which name would fit better.

Please do not use 'strand'. It's an existing different concept in Asio
which will majorly confuse any user if you go with it.

I'd recommend 'fiber', not getting stuck up on platform specific names.
After all, you've got things like the Windows mutexes which are IPC
primitives, while the 'mutex' in Boost.Thread is intra-process.

I'm opposed to the "Stratified" and "stratum" names, as they do not
really mean anything relevant, and as far as I know, have never been
used in literature to mean user-level threading.

Lars Viklund | zao_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at