Boost logo

Boost :

Subject: Re: [boost] [config] Add BOOST_NO_RANGE_BASED_FOR macro?
From: Marshall Clow (mclow.lists_at_[hidden])
Date: 2012-07-09 14:42:27

On Jul 9, 2012, at 11:34 AM, Beman Dawes wrote:

> On Mon, Jul 9, 2012 at 12:11 PM, John Maddock <boost.regex_at_[hidden]> wrote:
>>> 2) If you have to add a config flag, please match the CXX11 naming scheme
>>> and call it something like
>> +1 for that name.
> I really don't want to change naming schemes this far into it. If we
> go down that road, we should also rename the 28 Macros that don't use
> that scheme.
> Are you suggesting we should just byte the bullet and change them all?

Yes, I am.

I suggest that we do the same thing that I did for 1.50 and all the BOOST_NO_0X_* macros.
Define new ones, make the old ones have the same value as the new ones, and then, down the road, kill off the old ones.

See trunk/boost/config/suffix.hpp.

I even think that renaming all the macros (while keeping the old names around; not necessarily changing client code) is worth doing for 1.51.

-- Marshall

Marshall Clow Idio Software <mailto:mclow.lists_at_[hidden]>

A.D. 1517: Martin Luther nails his 95 Theses to the church door and is promptly moderated down to (-1, Flamebait).
        -- Yu Suzuki

Boost list run by bdawes at, gregod at, cpdaniel at, john at