Subject: Re: [boost] [TypeErasure]_self
From: Steven Watanabe (watanabesj_at_[hidden])
Date: 2012-07-22 23:50:25
On 07/22/2012 08:27 AM, Markus Werle wrote:
> you ask for feedback:
> I would be perfectly happy with _ instead of _self.
> You would be in sync with the folks that wrote C# Reactive Extensions
> who have the convention that _ stands for "unused", which it is here, too.
Except that it doesn't mean "unused."
It's the default, but otherwise it's
exactly the same as any other placeholder.
> To me
> constructible<_(const std::string&)>
> reads fine.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk