Boost logo

Boost :

Subject: Re: [boost] [context] boost::ctx::?
From: Jamie Allsop (ja11sop_at_[hidden])
Date: 2012-09-14 18:09:46


>> If the namespace is changed, I will prefer that the name convey the
>> functionality behind the context class. We can have a lot of context.
>> The functionality is close to a continuation context, but I don't know
>> if it implements it completely, so maybe continuation could be
>> considered.
> 'continuation' would be longer than 'context' - is a short namespace not
> preferable?
> The same applies to 'coroutines' - I would prefer 'coro'.

FWIW - I think 'coro' is cryptic at best. It is neither an abbreviation
nor an actual word, merely a truncation. As others have said, if you
want something shorter for clarity in a local context, use an alias.


> Oliver
> Oliver
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at