Boost logo

Boost :

Subject: Re: [boost] Boost.Test updates in trunk: need for (mini) review?
From: Robert Ramey (ramey_at_[hidden])
Date: 2012-10-20 15:25:48


Steven Watanabe wrote:
>> I. New testing tool BOOST_CHECKA
>>
>> This tool is based on excellent idea from Kevlin Henney. I chose the
>> name CHECKA for this tool due to the lack of better name, but I am
>> open to suggestions.
>
> BOOST_CHECK_EXPR? Ideally I'd like this
> to be called BOOST_CHECK, but I don't
> think that can be made perfectly backwards
> compatible.

How about BOOST_CHECK_EXPRESSION ?

>> II. New "data driven test case" subsystem
>>
>> <snip>
>> Here are couple examples:
>>
>> int samples1[] = {1,2,3};
>> BOOST_DATA_TEST_CASE( t1, samples1, sample )
>> {
>> BOOST_CHECKA( foo(sample) > 0 );
>> }

How about

BOOST_TEST_FOREACH(<test?>, <collection>, <item name>) ?

Robert Ramey


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk