Boost logo

Boost :

Subject: Re: [boost] Boost.Test updates in trunk: need for (mini) review?
From: Alexander Lamaison (awl03_at_[hidden])
Date: 2012-10-22 13:57:04

Gennadiy Rozenal <rogeeff_at_[hidden]> writes:

> Alexander Lamaison <awl03 <at>> writes:
>> Or just BOOST_TEST as that is now the default testing tool? TEST_CHECK
>> an TEST_ASSERTION etc. are redundant as it says the same thing twice.
> I need 3 names: warn, check and require levels. What do you propose?

I'd call the check version BOOST_TEST and the require version
BOOST_TEST_REQUIRE as it's not the tool you immediately reach for. I
must admit, I've no idea what the warning variant does. How does that
differ from CHECK? I can't find it documented here [1].



Boost list run by bdawes at, gregod at, cpdaniel at, john at