Subject: Re: [boost] Boost.Test updates in trunk: need for (mini) review?
From: Alexander Lamaison (awl03_at_[hidden])
Date: 2012-11-04 05:12:15
Gennadiy Rozenal <rogeeff_at_[hidden]> writes:
> Jeffrey Lee Hellrung, Jr. <jeffrey.hellrung <at> gmail.com> writes:
>> > > f) grid - dataset constructed by "multiplying" 2 datasets of
>> > the different sizes and types
>> > For people with a database background, "cross product" is the obvious name
>> > for this. Calling it anything else is silly.
>> Uh, this is Cartesian product , not a cross product , as far as I'm
>> concerned. Cartesian product > grid > cross product.
> Cartesian product is probably the right name, but it sounds too formal to me
> personally. I'd like this to be clear in "layman" terms.
Even the laymen here will have sat through (and passed) an intermediate
school maths course so will know what a cartesian product is. Grid, on
the other hand, could mean all sorts of things so ends up meaning
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk