Boost logo

Boost :

Subject: Re: [boost] Boost.Test updates in trunk: need for (mini) review?
From: Dave Abrahams (dave_at_[hidden])
Date: 2012-11-04 22:00:26

on Sun Nov 04 2012, Alexander Lamaison <> wrote:

> Gennadiy Rozenal <rogeeff_at_[hidden]> writes:
>> Jeffrey Lee Hellrung, Jr. <jeffrey.hellrung <at>> writes:
>>> > > f) grid - dataset constructed by "multiplying" 2 datasets of
>>> > the different sizes and types
>>> > For people with a database background, "cross product" is the obvious name
>>> > for this. Calling it anything else is silly.
>>> Uh, this is Cartesian product [4], not a cross product [5], as far as I'm
>>> concerned. Cartesian product > grid > cross product.
>> Cartesian product is probably the right name, but it sounds too formal to me
>> personally. I'd like this to be clear in "layman" terms.
> Even the laymen here will have sat through (and passed) an intermediate
> school maths course so will know what a cartesian product is. Grid, on
> the other hand, could mean all sorts of things so ends up meaning
> nothing.

When understanding matters, a term for which web searching will produce
a precise and unambiguous definition beats a casual but fuzzy "layman"
term every single time.

Dave Abrahams
BoostPro Computing                  Software Development        Training             Clang/LLVM/EDG Compilers  C++  Boost

Boost list run by bdawes at, gregod at, cpdaniel at, john at