Boost logo

Boost :

Subject: Re: [boost] [iterator] [property_map] Enhancement proposals
From: Louis Dionne (louis.dionne92_at_[hidden])
Date: 2012-11-10 14:46:10


This is just to request feedback on the new chained_output_iterator that was
proposed a while ago as an addition to the Boost.Iterator library. I have
written unit tests and documentation and submitted it on boost trac. However,
the ticket is assigned to "dave" instead of you so I just wanted to make sure
you were aware of it. The ticket is #7597.

Also, I would like to know whether you find the mean for doing iterator
composition and its implementation satisfactory (using the and_then() method).


Louis Dionne

P.S.: I changed the name to transform_output_iterator, which is more accurate.

Boost list run by bdawes at, gregod at, cpdaniel at, john at