Boost logo

Boost :

Subject: Re: [boost] [iterator] [property_map] Enhancement proposals
From: Jeffrey Lee Hellrung, Jr. (jeffrey.hellrung_at_[hidden])
Date: 2012-11-11 13:35:18

On Sat, Nov 10, 2012 at 11:46 AM, Louis Dionne <louis.dionne92_at_[hidden]>wrote:

> Hello,
> This is just to request feedback on the new chained_output_iterator that
> was
> proposed a while ago as an addition to the Boost.Iterator library. I have
> written unit tests and documentation and submitted it on boost trac.
> However,
> the ticket is assigned to "dave" instead of you so I just wanted to make
> sure
> you were aware of it. The ticket is #7597.
> Also, I would like to know whether you find the mean for doing iterator
> composition and its implementation satisfactory (using the and_then()
> method).
> Regards,
> Louis Dionne
> P.S.: I changed the name to transform_output_iterator, which is more
> accurate.

Great thanks Louis. Sadly I won't be able to review it until the week after
next, I think. If it starts languishing be sure to ping me :)

- Jeff

Boost list run by bdawes at, gregod at, cpdaniel at, john at