Boost logo

Boost :

Subject: Re: [boost] Another set of macros to deprecate (and then remove)?
From: Steve M. Robbins (steve_at_[hidden])
Date: 2012-12-14 11:38:36

On Thu, Dec 13, 2012 at 07:53:06AM -0800, Marshall Clow wrote:
> There are a set of macros in Boost.config that describe "features that are not required by the C++ standard"
> Some of these features have been incorporated into C++11.
> I propose that we retire these macros, and have people use the shiny C++11 versions.
> In particular:

I'm curious why Boost is changing from a positive macro "system has
feature X" to a negative one. Of the two options:

#ifdef BOOST_HAS_X


#ifndef BOOST_NO_X

I personally find the former much easier to read and the latter
double-negative version awkward enough to be error prone. Am I alone
in this opinion?


Boost list run by bdawes at, gregod at, cpdaniel at, john at