Boost logo

Boost :

Subject: Re: [boost] [chrono/date] class names
From: Rob Stewart (robertstewart_at_[hidden])
Date: 2013-05-12 22:41:50

On May 12, 2013, at 9:33 PM, Howard Hinnant <howard.hinnant_at_[hidden]> wrote:

> On May 11, 2013, at 7:13 PM, Vicente J. Botet Escriba <vicente.botet_at_[hidden]> wrote:
>> What do you think to using namespaces instead of prefixes?
>> This will allow to have checked and unchecked unit specifiers as well.
>> using chrono::checked;
>> serial_date dt = may/11/year(2013);
>> using chrono::unchecked;
>> serial_date dt = may/11/year(2013);
> This is an interesting idea. However I'm having serious doubts that we want duplicate checked and unchecked API's.


> Bottom line: N3344 has some very valid criticisms. But we should not limit ourselves to addressing those criticisms in exactly the way N3344 suggests. There are other (and I think better) possibilities. And I really dislike the checked/unchecked interfaces when the performance difference between the two is only a few percent (more work needed to absolutely nail down that this is in fact the case).

I like the simplicity of this tack. Note that the standard date types need not be the fastest possible, provided that user-defined types can interoperate well enough. The standard should be about generally useful types that are safe to use right, even at the cost of some performance. (When the two coincide, all the better.)


(Sent from my portable computation engine)

Boost list run by bdawes at, gregod at, cpdaniel at, john at