Subject: Re: [boost] [multiprecision] Are these types suitable as numeric types for unit tests?
From: Christopher Kormanyos (e_float_at_[hidden])
Date: 2013-06-08 15:08:32
>> This time it's an error, at Line 59 of
> Maybe it's the same phenomenon I am tracing right now.
> I encountered it with BOOST_TEST_CLOSE_FRACTION.
Oh, that's my forgetfullness. Disabling expression templates
does the trick.
Here is another weird one:
When using BOOST_TEST_CLOSE_FRACTION with
cpp_dec_float and et_off, I get a lot of ambiguous name
errors for enable_if and disable_if in multiprecision.
It seems as though the same symbols enable_if and
disable_if reside in both the namespace boost as well
as deeper in the boost::test namespaces.
Is this a known problem? Am I doing something wrong?