Boost logo

Boost :

Subject: Re: [boost] [thread] synchronized_value: value and move semantics
From: Vicente J. Botet Escriba (vicente.botet_at_[hidden])
Date: 2013-06-27 14:47:56

Le 26/06/13 21:56, Andrey Semashev a écrit :
> On Wednesday 26 June 2013 15:39:27 you wrote:
> Also, if it's not too late yet:
> 4. Could synchronized_value be renamed to just synchronized? Besides being
> shorter, this naming seems to be aligned with optional and reads more
> naturally. Consider:
> optional< int > oi;
> synchronized< queue< int > > sqi;

I could change it if there is an agreement of the Boost community.


Boost list run by bdawes at, gregod at, cpdaniel at, john at