Subject: Re: [boost] [thread] synchronized_value: value and move semantics
From: Vicente J. Botet Escriba (vicente.botet_at_[hidden])
Date: 2013-06-27 14:48:55
Le 27/06/13 09:49, Bjorn Reese a écrit :
> On 06/26/2013 09:56 PM, Andrey Semashev wrote:
>> 4. Could synchronized_value be renamed to just synchronized? Besides
>> shorter, this naming seems to be aligned with optional and reads more
>> naturally. Consider:
>> optional< int > oi;
>> synchronized< queue< int > > sqi;
> And the synchronize() function could be renamed to hold() to make the
> names more discernible.
I could change it if there is an agreement of the Boost community.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk