Boost logo

Boost :

Subject: Re: [boost] [modularization] Improving/splitting up detail
From: Rob Stewart (robertstewart_at_[hidden])
Date: 2013-11-02 08:20:02

On Nov 2, 2013, at 4:35 AM, "John Maddock" <john_at_[hidden]> wrote:

>>> The goal is to create two 'modules' or libraries:
>> We had that originally. They were called "detail" and "core".
>> I prefer to have no such "detail" libraries at all. Everything that is useful to a broader audience should be in utility.
> Funnily enough I was about to suggest just that: lets do away with detail and have:
> core:
> everything in:
> boost/detail/
> boost/pending/
> boost/utility/
> That has no dependencies.
> Utility:
> As above, but with dependencies (mostly to mpl/pp/type_traits).
> throw_exception.hpp and dependencies should go in core too, as would a few headers under boost/ such as cstdint.hpp etc.

That seems like a good idea provided that everything now in namespace detail remains in that namespace.


(Sent from my portable computation engine)

Boost list run by bdawes at, gregod at, cpdaniel at, john at