Boost logo

Boost :

Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: John Maddock (john_at_[hidden])
Date: 2013-11-06 04:07:31

> Oh yeah. You're right again, and I flubbed up again. Thanks.
>> How about:
>> cpp_bin_float_single;
>> cpp_bin_float_double;
>> cpp_bin_float_quad;
> Fine with me! Those are good names --- consistent with
> existing Boost style, easy to recognize, and unambiguous.
> Can we get a consensus on those names?

One other suggestion:


which keeps the "cuteness" and link to the names of the hardware types, but
the cpp_ prefix indicates it's a software emulation?


Boost list run by bdawes at, gregod at, cpdaniel at, john at