Boost logo

Boost :

Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: John Maddock (john_at_[hidden])
Date: 2013-11-17 07:01:57

>> Oh yeah. You're right again, and I flubbed up again. Thanks.
>>> How about:
>>> cpp_bin_float_single;
>>> cpp_bin_float_double;
>>> cpp_bin_float_quad;
>> Fine with me! Those are good names --- consistent with
>> existing Boost style, easy to recognize, and unambiguous.
>> Can we get a consensus on those names?

Unless there are strong objections I plan to go with those names - also
merge all the code to SVN Trunk fairly soon.


1) The types aren't actually 32/64/128 bits in size, merely emulating types
that are.
2) The cpp_bin_float128_t names are too close to the decimal-digit names for
comfort (ie potentially confusing).
3) Other than quad precision, I doubt many folks will use these anyway, so
lets just paint the bike shed and be done with it ;-)


PS to Paul (and anyone else interested): can I get you look at the revised
numeric_limits docs as I've made some changes to your original draft:

Boost list run by bdawes at, gregod at, cpdaniel at, john at