Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: John Maddock (john_at_[hidden])
Date: 2013-11-06 12:04:19
> I'm not a user of Boost.Multiprecision, but maybe namespaces would do
> a better job in distinguishing the types? Injecting various tags into
> the type names feels like C-style.
> Or maybe a trait to construct the necessary type:
> template< unsigned int Bits >
> struct floating_point
> typedef ... hardware_type; // optional
> typedef ... emulated_type;
> typedef ... type; // hw, if available, emulated otherwise
> typedef floating_point< 32 >::type my_float32_t;
> Just some thoughts...
Lets not over complicate these :-)
Actually I'm pretty sure these typedefs will be hardly ever used, but
they're useful for exposition.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk