Boost logo

Boost :

Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: John Maddock (john_at_[hidden])
Date: 2013-11-06 12:02:36

>> One other suggestion:
>> cpp_float32_t
>> cpp_float64_t
>> cpp_float128_t
>> which keeps the "cuteness" and link to the names of the hardware types,
>> but the cpp_ prefix
> indicates it's
>> a software emulation?
> I think I like these a bit better - except that should they be
> cpp_bin_float32_t
> cpp_bin_float64_t
> cpp_bin_float128_t
> I know it's more to type, but it's important that they are recognised as a
> binary type?

Those are rather similar to:


to me, which have their digit counts in base 10.

> Is double always 64 bit and float always 32?
> And quad isn't a float-point type yet?

It may be long double on some platforms.

Still painting the bike shed yours, John.

Boost list run by bdawes at, gregod at, cpdaniel at, john at