Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: Christopher Kormanyos (e_float_at_[hidden])
Date: 2013-11-06 14:10:08
> I think I like these a bit better - except that should they be
I can go with those, too. They are also good names.
On Wednesday, November 6, 2013 10:53 AM, Paul A. Bristow <pbristow_at_[hidden]> wrote:
> -----Original Message-----
> From: Boost [mailto:boost-bounces_at_[hidden]] On Behalf Of John Maddock
> Sent: Wednesday, November 06, 2013 9:08 AM
> To: boost_at_[hidden]
> Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
> >> How about:
> >> cpp_bin_float_single;
> >> cpp_bin_float_double;
> >> cpp_bin_float_quad;
> > Fine with me! Those are good names --- consistent with existing Boost
> > style, easy to recognize, and unambiguous.
> > Can we get a consensus on those names?
> One other suggestion:
> which keeps the "cuteness" and link to the names of the hardware types, but the cpp_ prefix
> a software emulation?
I think I like these a bit better - except that should they be
I know it's more to type, but it's important that they are recognised as a binary type?
Is double always 64 bit and float always 32?
And quad isn't a float-point type yet?
Paul A. Bristow,
Prizet Farmhouse, Kendal LA8 8AB UK
+44 1539 561830 07714330204
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk