Boost logo

Boost :

Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: Christopher Kormanyos (e_float_at_[hidden])
Date: 2013-11-17 08:50:50


>>> How about:
>>> cpp_bin_float_single;
>>> cpp_bin_float_double;
>>> cpp_bin_float_quad;

>> Fine with me! Those are good names --- consistent with
>> existing Boost style, easy to recognize, and unambiguous.
>> Can we get a consensus on those names?

> Unless there are strong objections I plan to go with
> those names - also merge all the code to SVN Trunk
> fairly soon.

OK, great. Sounds fine.

I keep using cpp_bin_float off-and-on. I have not encountered
any problems. I would like to look at overflow / underflow
for add, sub, mul, div. In addition, I find that the performance
drops way down as the digit count increases --- even worse than
cpp_dec_float. But this old hat and not relevant regarding trunk.
(Because we already know that we need more advanced
multiplication routines if we want to support high digit counts.)
I think it's great that you took on radix-2 big float, John.
Thank you.

Sincerely, Chris.

On Sunday, November 17, 2013 1:01 PM, John Maddock <john_at_[hidden]> wrote:
 
>> Oh yeah. You're right again, and I flubbed up again. Thanks.
>>
>>> How about:
>>> cpp_bin_float_single;
>>> cpp_bin_float_double;
>>> cpp_bin_float_quad;
>>
>> Fine with me! Those are good names --- consistent with
>> existing Boost style, easy to recognize, and unambiguous.
>> Can we get a consensus on those names?

Unless there are strong objections I plan to go with those names - also
merge all the code to SVN Trunk fairly soon.

Rationale:

1) The types aren't actually 32/64/128 bits in size, merely emulating types
that are.
2) The cpp_bin_float128_t names are too close to the decimal-digit names for
comfort (ie potentially confusing).
3) Other than quad precision, I doubt many folks will use these anyway, so
lets just paint the bike shed and be done with it ;-)

John.

PS to Paul (and anyone else interested): can I get you look at the revised
numeric_limits docs as I've made some changes to your original draft:
https://svn.boost.org/svn/boost/sandbox/multiprecision.cpp_bin_float/libs/multiprecision/doc/html/boost_multiprecision/tut/limits.html


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk