Boost logo

Boost :

Subject: Re: [boost] Standalone boost::ignore_unused_variable_warning()
From: Glen Fernandes (glen.fernandes_at_[hidden])
Date: 2014-05-19 13:39:56

On Mon, May 19, 2014 at 10:07 AM, Antony Polukhin wrote:
> I'd prefer to see a single function name, not two:
> boost::ignore_unused_variables(v1) ;
> boost::ignore_unused_variables(v1, v2, v3);
> boost::utility:: namespace looks reasonable. +1

It feels more like a workaround, than a utility, and so I would have
thought that:
 a. The more natural home is Boost.Config
 b. The macro approaches were preferable

I also like the idea of not adding new things to Boost.Utility going
forward (even if they only depend on Boost.Config).


Boost list run by bdawes at, gregod at, cpdaniel at, john at