Boost logo

Boost :

Subject: Re: [boost] Standalone boost::ignore_unused_variable_warning()
From: Antony Polukhin (antoshkka_at_[hidden])
Date: 2014-05-19 13:07:31


2014-05-19 19:26 GMT+04:00 Adam Wulkiewicz <adam.wulkiewicz_at_[hidden]>:
<...>

> Then probably also
>
> boost::ignore_unused_variable(v1) ;
> boost::ignore_unused_variables(v1, v2, v3);
>
> for consistency.
>

I'd prefer to see a single function name, not two:

boost::ignore_unused_variables(v1) ;
boost::ignore_unused_variables(v1, v2, v3);

> Or would putting it in boost::utility/BOOST_UTILITY be a better idea?
>

boost::utility:: namespace looks reasonable. +1

-- 
Best regards,
Antony Polukhin

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk