Boost logo

Boost :

Subject: Re: [boost] [concept_check] Standalone boost::ignore_unused_variable_warning()
From: Adam Wulkiewicz (adam.wulkiewicz_at_[hidden])
Date: 2014-05-20 06:45:49


Rob Stewart wrote:
> On May 19, 2014 11:26:49 AM EDT, Adam Wulkiewicz <adam.wulkiewicz_at_[hidden]> wrote:
>> Then probably also
>> boost::ignore_unused_variable(v1) ;
>> boost::ignore_unused_variables(v1, v2, v3);
>> for consistency.
> Actually, I'd favor ignore_unused(). I see no reason for "variable" to be in the name. If you use a macro, then you'd need to distinguish between TYPEDEFs and VARIABLEs.

I like those new names but don't forget that function
ignore_unused_variable_warning() is already used around Boost. Grep
shows ~600 uses in the code of various libraries and ~100 in the docs.

And to be honest, I like this long name. When I read it I have an
impression that it's not a part of the algorithm. But maybe I got used
to it.

I'm also curious what the author/maintainer of ConceptCheck thinks about
it? Jeremy are you reading this thread?


Boost list run by bdawes at, gregod at, cpdaniel at, john at