Boost logo

Boost :

Subject: Re: [boost] [review] Convert library
From: Vladimir Batov (Vladimir.Batov_at_[hidden])
Date: 2014-05-25 23:54:03

On 05/26/2014 01:36 PM, feverzsj wrote:
>> There is
>> convert(Converter const&)
>> It'll probably clash with
>> convert(TypeIn const&)
> that's why I suggested using two names(conv_to and convert) in the first
> place. The implementation could also be effectively simplified.

Ah, sorry. I missed that. There've been quite a few suggestions
regarding the name in particular, regarding the signature and all. I
feel overwhelmed. I feel, no matter what I choose, I'll end up defending
it... and I am running out of ammunition. :-) There are only two ways
that I can see how to proceed 1) I say "I do it my way" but then it
makes it my library rather than Boost library and I am uncomfortable
doing that; 2) try and unify all the input so far into a coherent
requirements specs, have it voted and proceed implementing it... Oh,
there is a third way out of this tight spot -- this proposal gets
rejected... and all gets peaceful and quiet again... I love peace and
quiet... :-)

Boost list run by bdawes at, gregod at, cpdaniel at, john at