Subject: Re: [boost] Proposal: Boost.Core
From: Mostafa (mostafa_working_away_at_[hidden])
Date: 2014-06-01 12:19:00
On Sun, 01 Jun 2014 08:34:01 -0700, Peter Dimov <lists_at_[hidden]> wrote:
> I'd be much happier if empty_deleter is called null_deleter though.
> empty_deleter always makes me think of empty deleter optimizations, and
> null_deleter, while not necessarily a better name, does have an
> established meaning.
I suggest "noop_deleter". At first glance "null_deleter" conveys that it's
a deleter for null pointers.