Subject: Re: [boost] Proposal: Boost.Core
From: Peter Dimov (lists_at_[hidden])
Date: 2014-06-01 11:34:01
Andrey Semashev wrote:
> How about moving:
> - utility/empty_deleter.hpp
> - utility/explicit_operator_bool.hpp
> - utility/swap.hpp
I was going where dependencies took me, and didn't stumble upon these three.
Of them, explicit_operator_bool is a no-brainer for inclusion per all
criteria. The other two are more in the gray. empty_deleter is only used by
log; swap is more widely used, but avoiding it as a dependency is trivial,
one just writes using std::swap; std::swap( x, y ) instead of boost::swap(
x, y ).
Still, they all probably do belong in Core. I'd be much happier if
empty_deleter is called null_deleter though. empty_deleter always makes me
think of empty deleter optimizations, and null_deleter, while not
necessarily a better name, does have an established meaning. (Also, op()
needs to be templated on T*, because it doesn't support shared_ptr<void(),
> cstdint.hpp, I think, should go into Boost.Config.
Either way is fine with me. I would personally have put it into Core because
I think that there's been much pressure recently to fit all kinds of things
into Config just because it was the only core library until now. But
cstdint.hpp _is_ a workaround header. So... whichever. Let's just decide
quickly and move it somewhere. :-)
Our next target should be the so-called Detail library. Most "detail"
headers probably belong someplace else.