Subject: Re: [boost] [GSoC] [Boost.Hana] Formal review request
From: pfultz2 (pfultz2_at_[hidden])
Date: 2014-07-30 17:37:47
> Then again, if the interface of hana::fmap is nothing like the interface
> to std::accumulate, it could lead to confusion. The MPL names work in
> part because MPL is STL-ish design (containers/iterators/algorithms).
> Just throwing that out there. No strong feelings. Naming Is Hard.
Also, I would like to mention that some names don't have exact equivalents
C++. For example, `bind` could be called `flat_transform`, however, that
really only makes sense for sequences. Although, I do think, it would be
better not to call it `bind` since it already means something else to C++
programmers, so another name could avoid confusion, I'm not sure what that
name would be(perhaps `apply` or `compute`?).
Also, I think it would be better to call the `Monad` concept, `Computation`
like that, since monad doesn't mean anything at all outside the FP
Just some additional thoughts and suggestions. Naming, of course, is hard.
-- View this message in context: http://boost.2283326.n4.nabble.com/Re-GSoC-Boost-Hana-Formal-review-request-tp4665622p4665841.html Sent from the Boost - Dev mailing list archive at Nabble.com.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk