Boost logo

Boost :

Subject: Re: [boost] [GSoC] [Boost.Hana] Formal review request
From: Eric Niebler (eniebler_at_[hidden])
Date: 2014-07-30 12:57:58

On 7/29/2014 2:17 PM, pfultz2 wrote:
> Here's a few list of names off the top of my head that could use more
> C++-like
> names:
> foldl = fold
> foldr = reverse_fold
> fmap = transform
> cons = push_front
> scons = push_back
> datatype = tag,tag_of
> head = front
> last = back
> typeclass = concept

Then again, if the interface of hana::fmap is nothing like the interface
to std::accumulate, it could lead to confusion. The MPL names work in
part because MPL is STL-ish design (containers/iterators/algorithms).

Just throwing that out there. No strong feelings. Naming Is Hard.


Boost list run by bdawes at, gregod at, cpdaniel at, john at