Boost logo

Boost :

Subject: Re: [boost] [git][align][litre] git submodule update failure.
From: Mostafa (mostafa_working_away_at_[hidden])
Date: 2014-09-07 15:47:06

On Sat, 06 Sep 2014 01:53:20 -0700, Daniel James <dnljms_at_[hidden]> wrote:

> On 6 September 2014 03:11, Mostafa <mostafa_working_away_at_[hidden]>
> wrote:
>> $ git submodule update libs/align
>> fatal: reference is not a tree: d32353ea7d39c0237202e3e460f3248f226db274
>> Unable to checkout 'd32353ea7d39c0237202e3e460f3248f226db274' in
>> submodule
>> path 'libs/align'
>> $ git submodule update tools/litre
>> fatal: reference is not a tree: 564d4d8d30b7e03ac5e25d78e14d2c19fa321c83
>> Unable to checkout '564d4d8d30b7e03ac5e25d78e14d2c19fa321c83' in
>> submodule
>> path 'tools/litre'
> 'litre' hasn't changed since the git conversion, so if you had a
> previously good checkout it should still be there, so there's possibly
> something wrong with your clone. Try going to the submodule's
> directory and running 'git fetch'.
> Also, do you have any remotes pointing at other locations? Git might
> be fetching from the wrong place. I find it best to keep the
> 'boostorg' as origin, and any forks as other branches. Also, if the
> submodule's current branch is tracking another remote, it will fetch
> from there (which seems wrong to me, it should really fetch from the
> remote that the super-project refers to).

Thanks for the info. None of the workarounds suggested in this thread or
elsewhere worked. I eventually had to make a new clone, and that worked.
(Most google search pinned the blame for this type of error on some
upstream mismatch, but obviously that was not it in this case.)

Boost list run by bdawes at, gregod at, cpdaniel at, john at