Boost logo

Boost :

Subject: Re: [boost] [OpenOffice] [Boost_Document_Library] [GSoC'15] Unable to compile and run the examples in the OpenOffice SDK
From: Rob Stewart (rob.stewart_at_[hidden])
Date: 2015-04-22 17:44:38

On April 22, 2015 12:05:27 PM EDT, Abhinav Tripathi <ee130002001_at_[hidden]> wrote:
> When i tried to compile any example in
> /opt/openoffice4/sdk/examples/DevelopersGuide/ProfUNO/ i got many
> errors..
> .
> To overcame some of these i did :
> 1. copied all files from /opt/openoffice4/sdk/bin/ to my root folder
> /bin/
> because the error said /bin/cppumaker : command not found

Editing PATH should have been enough.

> 2. Used a conf file to load all libraries in linux linker cache...
> using
> sudo ldconfig
> because g++ showed error that was not found!

Setting LD_LIBRARY_PATH should have solved that though one should try to avoid having to do that all of the time.

> 3. copied the types.rdb file from sdk folder to my root folder /
> because it
> said something about registries not loaded.

I know nothing of that.

> 4. made a few variables in the makefile like OO_SDK_HOME, JAVA_HOME,
> JAVA_BIN to allow compilation...

Some of those may have helped before steps 1-3.

> 5. Made folder for each example in
> /opt/openoffice4/sdk/LinuxExamples.out/bin folder because g++ always
> gave
> the error that the there was no file or folder of the name of the
> example
> that i was compiling.

I have no idea what's wrong there.

> Now, i am able to compile the examples but when i try to run them with
> cd ../../../../LINUXexample.out/bin && office_connect
> /bin/sh: 1: office_connect: not found

Adjust PATH?

> Makefile:100: recipe for target '' failed
> make: *** [] Error 127
> I think it is because of this line in the makefile :
> $(OUT_BIN)/%$(EXE_EXT)
> cd $(subst /,$(PS),$(OUT_BIN)) && $(basename $@)

Yes, that target produces the command line you showed above. Obviously, the examples are assumed to be run from a directory six or so levels deep, hence "cd ../../../../LINUXexample.out/bin". OTOH, it could be that OUT_BIN is being defined incorrectly because something else isn't set.

> I have no experience of Makefiles and also i am new to openoffice
> sdk... I
> am guessing that these errors are happening beacause i installed the
> packages manually from dpkg instead of using apt-get...

I have no experience with the OpenOffice SDK, so I cannot offer any more concrete information.


(Sent from my portable computation engine)

Boost list run by bdawes at, gregod at, cpdaniel at, john at