Boost logo

Boost :

Subject: Re: [boost] [thread] Problem with thread test 'failed to write output file'
From: Edward Diener (eldiener_at_[hidden])
Date: 2015-06-02 22:43:22

On 6/2/2015 9:51 PM, Edward Diener wrote:
> Attempting to run the 'thread' tests locally I get:
> failed to write output file
> '..\..\..\bin.v2\libs\thread\test\upg_lock_cons_move_ctor_sh_lock_untl_p_lib.test\msvc-12.0\debug\threading-multi\sync\mutual_exclusion\locks\upgrade_lock\cons\move_ctor_shared_lock_until_pass.obj.rsp'!
> This is with the --abbreviated-path option.
> If I try using --hash or not using either on the b2 command line I still
> get the same result of 'failed to write output file ... etc,' probably
> because the output file spec is still too long.
> This happens on Windows thread tests with msvc-12.0 but not with gcc-4.9.2.
> Any ideas how I can get this to run successfully ?

Please ignore my message. It should have been --abbreviate-paths and
that actually worked where --hash did not.

Boost list run by bdawes at, gregod at, cpdaniel at, john at