Subject: Re: [boost] [metaparse] Update review
From: Rob Stewart (rob.stewart_at_[hidden])
Date: 2015-06-04 04:58:22
On June 4, 2015 1:30:28 AM EDT, Abel Sinkovics <abel_at_[hidden]> wrote:
> On 2015-06-04 06:45, Edward Diener wrote:
> > A couple of quibbles about the design based merely on my own sense
> > 'naming'. Since I have roundly criticized "naming wars" <g> in the
> > past I no doubt leave myself open for criticism, but these are just
> > personal suggestions, which I can live without:
> > * BOOST_STRING is very generic and can easily lead to a macro clash.
> > Something like BOOST_METAPARSE_STRING or maybe BOOST_MPS_STRING
> > be more distinct and safer. I favor shortened names for libraries in
> > macros to be 3 characters rather than 2 characters so as to decrease
> > macro clashes.
> I'm sure it won't remain BOOST_STRING. I'm open to BOOST_MPS_STRING as
META might be an appropriate middle if MP is considered too short, and is certainly better than MPS since the "S" is just extracted from the middle of "parse". METAPARSE makes for a very long name, so I favor MP from all of the options I've seen.
(Sent from my portable computation engine)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk